CSPM/KSPM Compliance data updates are delayed, causing some customers to see outdated compliance results.

Incident Report for Sysdig EU-Central-1

Resolved

The issue affecting CSPM/KSPM Compliance updates has been fully resolved. A fix has been deployed, and compliance scans are now completing successfully. We have confirmed that requests are processing normally and no further errors are occurring.
Posted Nov 26, 2025 - 20:54 UTC

Monitoring

We have tested a performance fix for the service causing delayed CSPM/KSPM Compliance updates, and initial results show that compliance scans are completing successfully again. We have started deploying this fix and are monitoring to confirm full recovery.
We will provide another update once we verify stability.
Posted Nov 26, 2025 - 20:21 UTC

Identified

We have identified the cause of the delayed CSPM/KSPM Compliance updates. The issue is related to timeouts in the service responsible for generating compliance results. Our engineering team is testing a fix and preparing a rollout to restore normal compliance view updates.
We will provide the next update once the fix is validated and deployment begins.
Posted Nov 26, 2025 - 19:12 UTC

Investigating

We are currently investigating delayed updates to CSPM/KSPM Compliance data that may cause some customers to see outdated results.
Posted Nov 26, 2025 - 11:53 UTC
This incident affected: Sysdig Secure.