Our team has been closely monitoring the environment since the last update, and compliance evaluations have remained stable with no new failures observed. We’ve also introduced additional retry logic in the compliance evaluation workflow to improve resilience during periods of high load. Monitoring will continue as we validate that performance remains consistent.
Posted Nov 29, 2025 - 01:01 UTC
Update
We have applied several improvements to address the intermittent failures in the compliance evaluation workflow. The system is currently stable, and we are continuing to monitor the environment to ensure compliance evaluations remain consistent across all affected regions
Posted Nov 28, 2025 - 20:33 UTC
Monitoring
We have fixed the backend timeouts causing intermittent failures in the compliance evaluation workflow. We are actively monitoring the environment to ensure compliance evaluations remain stable.
Posted Nov 28, 2025 - 09:28 UTC
Identified
We're again observing intermittent failures in the compliance evaluation workflow due to backend timeouts. We are currently working on fixing this.
Posted Nov 28, 2025 - 07:41 UTC
Monitoring
We have deployed a performance improvement to the backend service responsible for generating CSPM/KSPM Compliance views. Initial results show that the issues have been mitigated, and we have not observed new failures since the update. Our teams are continuing to closely monitor the environment to ensure compliance evaluations remain stable. We’ll share another update as soon as the fix is fully validated and consistent performance is confirmed.
Posted Nov 27, 2025 - 19:43 UTC
Identified
We're still seeing intermittent failures in the compliance evaluation workflow due to backend timeouts and memory pressure. Affected tasks complete with warnings and may leave compliance views showing stale data. Initial query optimizations are deployed, and further improvements are being tested. We'll expand the rollout once validation is complete and continue to monitor closely.
Posted Nov 27, 2025 - 14:40 UTC
Investigating
We are currently investigating delayed updates to CSPM/KSPM Compliance data that may cause some customers to see outdated results.