Recent backend efficiency enhancements have been deployed, and early results show improved stability. Our teams continue to monitor the system closely to ensure consistent behavior across all environments. Further updates will be shared as we validate full resolution.
Posted Nov 28, 2025 - 21:28 UTC
Update
We have identified the root cause of the delays in Jira ticket creation and deployed a fix to address the related issue. The update is now live in all affected regions. Our teams are actively monitoring the environment to ensure the service remains stable and fully restored. We will provide further updates as we confirm full resolution.
Posted Nov 27, 2025 - 20:23 UTC
Update
We've implemented a backend query optimization that has already improved Jira ticket creation performance, with early results showing noticeably faster execution times. We're continuing to monitor behaviour across all regions, while our teams validate the fix, review data consistency, and assess stability before making further changes. We'll share additional updates as we confirm sustained improvement.
Posted Nov 27, 2025 - 13:31 UTC
Monitoring
A partial mitigation is in place that allows Jira ticket creation to succeed intermittently, reducing user impact. Performance is still not fully stable, and our team is continuing work on the underlying query optimization. We will provide further updates as improvements are made.
Posted Nov 27, 2025 - 00:09 UTC
Update
We have identified that the delays in Jira ticket creation are caused by slow query execution in our backend data service. The team has applied a temporary mitigation by reducing the query timeframe, which has improved success rates partially, but the issue is not fully resolved. We are continuing to work on optimizations to restore normal performance. Further updates will be provided as progress is made.
Posted Nov 26, 2025 - 18:17 UTC
Identified
The issue has been identified and a fix is being implemented currently.
Posted Nov 26, 2025 - 08:35 UTC
Update
We continue to observe delays in the Jira ticket creation workflow used in our vulnerability management automation and our team is actively investigating. We will share more information as the analysis progresses.
Posted Nov 25, 2025 - 23:21 UTC
Investigating
We are experiencing degraded performance in the creation of Jira tickets as part of our Vulnerability Management automation. A fix is being deployed and investigation is ongoing.